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Error Handling

This article covers common import errors and their solutions. We'll update this article after getting more cases.

Updated over 3 weeks ago

Cases

1. Price Conversion Error

Error Message:

controller: failed to import segment [/home/runner/work/pdmgolambda/pdmgolambda/imports/importController.go:207] failed to ingest prices data [/home/runner/work/pdmgolambda/pdmgolambda/imports/importController.go:3997] failed to convert Price to float64 [/home/runner/work/pdmgolambda/pdmgolambda/domains/pricesheets/prices/model/imports.go:96] failed to convert string to float64 [/home/runner/work/pdmgolambda/pdmgolambda/utils/utils.go:366] strconv.ParseFloat: parsing "$ 85.00": invalid syntax

Cause:
Price fields contain currency symbols ($) that the system cannot parse.

Solution:

  • Format the Excel column as Text.

  • Remove currency symbols ($) from price values.

  • Use plain numeric values (e.g., 85.00 instead of $85.00).

2. Qualifier Unit of Measure Error

Error message

Error Message:controller: failed to import segment
[/home/runner/work/pdmgolambda/pdmgolambda/imports/importController.go:196] failed to import app default qualifiers
[/home/runner/work/pdmgolambda/ pdmgolambda/imports/importController.go:1793] failed to enrich item qualifier value meta uom id
[/home/runner/work/pdmgolambda/pdmgolambda/domains/items/domainService.go:373]

(with qualifiers containing parentheses)

Cause:
The system interprets content in parentheses () as Unit of Measur, but the values don't match valid UOMs.

Solution:

  • Replace parentheses with other characters like dashes - or colons :.

  • Change (Example) to - Example or : Example .

3. Part Number not found

Error Message:
​Part Number not found

Cause:
New part numbers exist in the imported file but not in PDM.

Solution:

  • You can import the Item segment along with the desired segment to create new part numbers.

  • Or you can enable Advanced Import Options when importing segments with new part numbers by selecting 'Yes' on Create new items.

General Troubleshooting Tips

  • Always check the Import Reports tab for detailed error information.

  • Download error files from the Actions column for specific row details.

  • Import segments in the correct order: Items β†’ other segments.

  • Check on the settings only the segments you're importing

  • Make sure all the tabs in Excel have the correct segment name. (Items, Applications, etc, instead of Sheet1, Sheet2, or other names)

  • Use Text format for any fields containing symbols, special characters, or non-numeric data.

  • Excel's row limit is 1,048,576, which means that not all the data may be exported; keep this in mind. If this happens and you hit that limit, we recommend creating filters or exporting in batches.

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